Scheduled for February 14, 2025 at 5:00 AM – 10:07 AM
Affects
Websites
Under maintenance from 5:00 AM to 10:07 AM
Billing
Under maintenance from 5:00 AM to 10:07 AM
Updates
Completed
February 14, 2025 at 10:07 AM
Completed
February 14, 2025 at 10:07 AM
Maintenance has completed successfully
In progress
February 14, 2025 at 5:00 AM
In progress
February 14, 2025 at 5:00 AM
Maintenance is now in progress
Planned
February 14, 2025 at 5:00 AM
Planned
February 14, 2025 at 5:00 AM
We’re performing scheduled maintenance to update our billing portal and launch our brand-new website! Servers will NOT be affected during this process. Your services will remain online without interruption.